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1 #Bir—4InH[

— AT H (Project) £ 1R A H et B v 7 %, S5 Th A Bk (Block), Thag K
(Chart), ‘BWREGL S ZAEHIRE, BE il S PMBTE K 2Rl 44 .

1.1 B SIMATIC Manager EiI—/MRH

T H & B CRE AT . 2 TR S, 7 Windows NT ST F4s
L SIMATIC L E$(SIMATIC Manager).

B3 SIMATIC Manager
AR5 53 SIMATIC Manager
o ENTS E, Wit STEPT Bk [
o 4% Start > SIMATIC > SIMATIC Manager
By —N B
¥ SIMATIC Manager J&, HEL “New Project” & H. #FFEMRSHUH Tk
Tk V&, WA R Hidr 4 File > ‘New Project ‘.
FIAFHEMBEENQ
1. TESE—ASXEHE, Hidi Continue 44 ;
2. {EH ASKHEHE “Which CPU will you use in your project?” , E##
i CPU 24, i1 CPU416—2DP.

PCS7 Agsistant: "New Project”
Which PLC will you use in pour project? 204)
PLC CPU type | Order No |

S7 program

CFPU414-2DP BESY 414-Z<101-0480

CPU41E-2 DF BEST 416-Z<K07-04B0
EELT 416-Z<L01-04ED

CPUA17-4 BEST 417-4<L00-04B0

WindC CPU4TE-ZDP IS4 BESY B16-2PKOT-04B4

1.6 KB work memory: 0.08 me/kA; 16 KB DIA0; B4 ;I
connections; MP1 + DP connections: with

multicarputing capabilite ﬂ
Prewigws > |
¢Back | Conlirue> | Make | Cancel | Help |

1§ F “ Preview >> 7 %4, %0 %6 84T JF 8% ¢ (1 “ Plant View ” 5%

“Component View” .

3. FEH =ANKHEHE “Which objects will you used in the project?” , #%#
ARG E s

1-1



NI

PCST Agtistant: ‘Mew Project’
| Which objects will be used in the project? 34
Plant hierarchy ~ PLL objects
PMumbes o el |3 - ¥ CEC chait
¥ SFC chat
05 objeclz
W WirkC pcture
7 WirlCT pepert
Prevdewsr I
<Bock [[Coniies | Make | Cocel | Heb |

4. FEEVYAXTIEHRE, FiA “Color” fE NI H 4R, ARJ51% “Make” 1%
.
AU IR B AR TR
7t SIMATIC Manager % HH, 2787  “Plant View” #  “Component
View” BT .

Plant View B94544

1-2

Plant View 448 T2 BERMAL NI H, A LTINS (% E,
WA, R ROE I — AN AR AL B

7E Plant View & O, 72 FAMGERRERRERINH, A4ty COLOR. il
HIWF— 2540 Plant(3E), W N 260 Unittk ), &5 — 2N
Function(Zht). REHARENZJZ, HENAR, AliE+ Plant, RJFIEFE
Mifr4: Options > Plant Hierarchy > Customize

eI EEHE Y, #F Number of hierarchy levers 174 N4 52 1250
ARSI, BATATEELE 2 Unit /e hdn 2 A H,  BRIAEXSEEHE T Include in
designation 17+, Hidi Level 1 1 Level 3 MR 7TAE, HUuH Hk$%.

Base picture on the plant hierarchy 6 &HE L /_#4E KK E R Plant
view 2R eE, EERE RS il Picture Tree Manager 2RI K 2 UCks:
T ¥t second level 15N )IZ RIS Z K.

BB UG IR HE 7R -
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Cuztomize Plant Hierarchy

Hurber of hisrarchy levels: |3 3:

Documertation prefe: |
~ Lewel Sethr i
Level  Max rumber  Includein With 05 area
of characters  designation separalon
s F3d o B e
Z g = = Il ol
X 8 53 i | F g
& 4 o |.7 s e s
& = F F i
Preview,  |22222222\
[ Dase pichure Fiesaichy on the planit histarchy
5| Bese SEIRH ertle confinimaton o= B et ety
s | o |

st OK KHIRHEHE, 447 tHILI IE$E Yes.

MAETTR i I H COLOR [H)2K:

1. JHAE S Plant BFR, 4% Insert New Object > hierarchy folder,
HIJZ K Unit2 HIL;
A4 S 5 Plant 45, 4% Object Properties, i A4 ¥k Plant1;
FI 45 8t 25 i Unit &k, 47 JF Object Properties, ik # % 7 OCM
Attribute, NEEEFEK AHE No changes when renaming the hierarchy
folders.
7t Object Properties % 1, EHR L General, K4 H¢ Unit 5 RTM1.
HFFE R, ¥ Function Bk FC 111,
BRI 3 AP 4, @ FEPRIE COLOR 2K,

OLOR (Plant Yiew) — C:-\SIEMENS\Color ![E]E{

ER=
=1-(g Planti
= (8 RMT1

o (g FOI11
| E(E L
(g NPT
w-(E] SFUNC

2| Global footer Dacumentation

(] Plantl
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14

FEJZ ARG AU A2

Plant1: TIRERE

RMT1: 15 JRORHRE

SFUNC: I F B eEl SFCy
FC111: i nill

LI111: WALHE R

NP111: Rl

EREZREY, AT 2XAMRE A AMERE, BRI .
SFC EHBEAT B CIRPR S IR, F R B IR ZESRk A7 SFC .
BAE, H SIMATIC Manager &7 [F30 H JZ K 1 TAE B4 58 .




2 {£H CFC “migss

CFC K ARIELAEHIK, M T R4S, XA SAMA &,
RENHUTHZE CFC K, WA MNEHIR I GEHLBLOCK), 45 Lhfiek it 2
e, DhRe I MERESE. PCS 7 &4 7 S ARHER R Tk hRELR, W1 PID
PE, BT LA

2.1 #3 CFCH

FATTH SIMATIC Manager @323 H COLOR i) CFC K. FC111 ZRGE 4
&—ACFC I, # A CFC1.

A ik CFC1, 1E$% Object properties

¥ CFC1 ¥4 FC111, fiidi OK.

A L 111 2R3, %488 Insert New Object > CFC, R4 LI 111 )2
R —A> CFC .

4. FATEEL L1,

w N -

2.2 {EANINEER

LA, AT ThREHL(Function Block)sR A &S HMTS o
5. &E L1111 2EKE.
6. il LI 111 CFC ), #EX CFC ZmiE 8.

CFC ElH%5#4
Sheet1 Sheet4
Sheet2 Sheet5
Sheet3 Sheet6

A CFC B4y 6 01, Hasiin F, &l Fo4s haonbess wox B 0L
5T LA FR A AN 2 S SRR O T 2 1) 4

2-1



i H CFC it 2%

B 1R 7 AR 4k SR T L AEAE R S SR AT . AR

K2,
o fliHlZMar4 Edit>Go To > Sheet, WEFAZH 1—6 2, HEAZIFHN T
[

BEAL, A U T DL A S T R AN T (02 11X, T b AR 0 7
MEE AR BRI BE R

§544 1] MEAS_MON i Jeis W J5URHAE R 3003 -

o sdiHzd B, frorohfete H

o EFEINREHLITICNO:

o USTTLEILZAE D MEAS_MON S5 2 HEHUFT 26 1%

W CFC - [Measuning —~ COLORAPlant] \Modelz\M easuning\i]

[ Chet b |need PLC Debug Wiew Dptians Eﬁhdm' Hek =181
(o] =3 = R = =
Sle=) @l =0 2= @la) =s5|m) el
= B =
=4 L}L, Lioeary [curent CFC
=M CFCLES o)
+ A coLor_ue
+ - 4l PCS 7 Corm Blacks
4 Ml FCS 7 Driven Blocks
41 PCS TEDC Blocks
= i FCS 7EDC Elocks
- Ml FCS 7 FiskiDevice Block_|
[ - i PCS 7 Techrol Blocks
+ - sreun
- SMATICHET CP =
] | _'l_I
O ®m. & &
T
T — o =
Press F1 fot help. [AfQverview  [DB35 SFCT 4

Fn R A BR58 i D B R 4 -

1. ¥ ) REHH R i 1

2. #z)) MEAS_MON I REHR | BT 1T 1 f18 A7 & s

3. R D REER P AR L 5

4. 7F Properties_Block_LI 111/1 XJiEHE, HAZFR LIA, iy OK, JCHIX)
THE 5

5. TEFEHREThfed INT_P, #e/gE it MEAS_MON IhfedeiZem, &
PR XA D Rk )7 B J5URHRE (1) AL

6. KrizThagkar 44 INT_P;

hfigd MEAS_MON B4 & 43%4y OS Sifffs B ICAR(MESSAGE TEXT), 4

MR . 7 EEME B SCA, A fE Special Object Properties H1 fiidi

Messages #2441, #AT1EH.

BRI

BRI H CH_AL IXENHUH T /O BEBRERBULRE(E,  #ededk CFC
A H R B A% =K

2-2



] CFC 9%

TR
PCS 7 sl & SR TASE R, X FR ) PGSR S AN
A PIQGE R S i ) o

1. M PCS 7 BRzhFEH R CH_Al FeThAelE LI 111, JE INT_P B4
i, FFavsa A INPUT_U,

PEAE O3 ON I DR ORE B A R — A BB E S OP_ALIM, & K

PARA_DOS_RM1_ QTY; i Rl B 7E 55 — Bl e, &N

PARA_DOS_RM1_VOL. JEklR[IES] V3 1 83 2, A

fEH OP_D ik#%, #v4 k) PARA_DOS_RM1_SEL. XUt#iigtr PCS 7

Technology EH.

2. Jl Edit>Go To>Sheet 2 #ir3HEAN LI 111 A5 T, HAIRE R4 T

npu ‘3"-"‘

Mo
TEAD

4 FE}
GUALITY BV

WAE, oegmANTIHm ks R d. K5, N PCS 7_CFC_
Templates JEH1#% ) MOTOR.  CFC B e H Tl B Tk sh e A, &l
FAB I EESKH DUFNE H X SRR

1. H Chart > Close iy % <] CFC S

2. | File>Open>library>PCS 7_CFC_Templates>OK it 44T TR 5 ;

3. R M S7 Program, #RJi s Charts;

4. £k MOTOR iR, k4% Copy;

5. FHZZ ¥iéir4 Window il COLOR i H ;

6. HA e RE NP111 2, ¥ Insert;

7. % MOTOR %444 NP111;

8. XA % Lhfe

2-3
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i H CFC it 2%

9. ¥ CH_DI Zhfigs 4 % FB_ON, CH_DO Ijfigd i 4 4 QRUN;

BiAE, NP111 Dhie A AeE.

T &t CFC KB FC111. iZIhfe K-S0k Rk RE ORG24 . i N
CTRL_PID (¥, £ PCS 7 HiARFEH), DOSE thzmtk, 7 PCS 7 #
AREEF), INT_P B2, 78 PCS 7 HKEEH), MUL_R (2P Kb, 7
CFC JE1) Elementa 1), CH_AIl Bh(#iftl#m ANk, 78 PCS 7 Drivers JEH1), DL
J CH_AO R (Fiftlsm B, 7 PCS 7 Drivers JFEH).,

GERE CUT B0}
EE_F

SUALITY EY

K:IIO TEACE

@0 F_UMRRHGE |
2. 0—{F_JRrrHiE |

2.3 BINERDTESH

HIT T 25 25 (¥ Th REBRIE N ¥ B S 40, B BCAT LA B K i A\ 6 20003 IR 1 1R 2

7 Object Properties X iFHER S B S5

Je4hy CFC LI 111 Bl B 5L

1. LESE HiE S WindowsLIT11, #EA I 1;

2. FATE B GIREP LIA HCEAS, B HREE N, D) Redk AR Tt &
IEHEAE R

3. Wi 444 LIA [ MEAS_MON Zh e bR, 4T 74 58

4. Bt Inputs/Outputs % 11T ;

5. %% U_WH H A\ (37 EIR)ME Sy 90:

6. Feln TG R HAL SR, AR KM 8 TS i



i H CFC it 2%

Block name Parameter |Value |Meaning
LIA MO_PVHR |100 Upper limit of the process value in the
(sheet 1) container 100 m®

U_AH 98 Upper alam limit 98 m?®

U_WL 7 Lower warning limit 7 m®

U_AL 5 Upper alam limit 5 m®
INT_P(sheet 1) U 0.4 Simulation of the raw material tank level

INPUT_U SIM_ON 1 Simulation value active
(sheet 1) SIM_V 78 Raw material tank level 78%
MODE 16#02 |Range 4 to 20 mA
03

VHRANGE [100 Upper measurig range

SIM_V 78 Raw material tank level 78%
PARA_DOS_RM1 |U 50 Setpoint of the flow control 50 Liter/Min
_QTY (sheet 2)
PARA_DOS_RM1 |U 5000 |Setpoint for dosing 5000 liters
_VOL (sheet 2)

U_HL 10000 |Limit value of the entry for the U paramelter
PARA_DOS_RM1 |10 1 The target reactor is reactor 1
_SEL (sheet 2)
E:

FEDNREHURMESC L, ST B E S MO8 AT L (Visible) BRANHT #(Invisible) o ANHT

MSH Bosfe ey a iR, A BorfEDhREskf CFC K.

NP111 &R

WiAE B NP111 ZhEg R CH_DI Zhagth g . F SIM_ON, &nI7E9Kz)th
PRI A . AR S H T R R R R E .
1. F Window>NP111 3Z#a54HEN NP111 DhfE

2. % NE5ic CH_DI (924

Block Name Parameter Value Meaning
FB_ON SIM_ON 1 Simulation activated
Motor Monitor Monitoring=off Monitoring deactivated

FC111 Th&EE

N E FC111 ik
1. e FC111 Zhig
2. 5 N RGREH A IS5

25




i H CFC it 2%

Block name |Parameter Value Meaning
MUL_R IN2 1 Change the input value to 60 Liters/min
INT_R V_HL 10000 Upper limit quantity summation 10000 Liters
Dose SP_HLM 10000 Upper limit of the setpoint for the dosing
volume

MO_PVHR 10000 Upper limit of the process value for the
dosing volume

SPEXON_L 1 Interconnection for the internal/external
switchover active
INPUT_U SIM_ON 1 Simulation activated
MODE 16#0203 |Range 4 to 20mA
VHRANGE 100 Upper measuring range
Ctrl LIOP_MAN_S |1 Interconnection automatic/manual active
EL
LIOP_INT_SE |1 Interconnection for the internal/external

L switchover active

—_

SPEXON_L Switch controller to external setopoint

GAIN 0.5 Set the gain of the controller to 0.5

2.4 NRERRIBEREE

2-6

NI L 111 DhRe I S AN Dy pe bk

1. Vi3] CFC ZhfelEl LI 111 B0 1;

2. piahi UyReE INPUT_U firth V, AR5 S ZhREd INT_P 1%\ VTRACK;
3. M DiReH INT_P it V, AR5 s Dyaedk LIA 15 U;

ZZ
;
-

g

b

T
I
x|
=T
E

1E
gE
sosroen

¥
|
-
2
2
2
£
-
2

@ @oge
T e

[__uH_WEN BOf
UL WEN BU)

DEB DD B

1.0—E_H¥s

WTRALCK,

U— BO_TRACH

n—{ B0 _HOLD

i
HRERE /O BAHERLIN, JELOR B BB, JEL AL E A IIEL ) fE -
AELAT IR,

o frHERELMEIAEHIE, RJGEF Delete Interconnection, MHIFRET
PRIELL

DhRER LI 111 TUif 2 _EREREThREt AN 5 A Dh R P 42, e R A7 il

1 G N B -




i H CFC it 2%

ThEEE NP111 B EHRiER:
Fe N EERDIREE NP111:

Thae®E FC111 B EHREIE
¥ N RER FC111:

BIE, IS8 T H COLOR iy CFC 41, TFIbki#5 DL RM1 JZ IR
—AEIE

2.5 EHIEANR R (Hierarchy)

fEHiH COLOR ', T2 MAHEIM JFORMGE, DItbny 45 DA RM1 J2 k4
A

8, F FC111 JZ2k& i) SFC By iR, 2 WA ) 2] SFUNC
JZIRA, VMET— 0¥ D1 SFC YjRe

1. 7F SIMATIC Manager Hi% £ FC111 |2 K%

2. At ridh SFC1 P oG, ik+e Cut(851));



i H CFC it 2%

3. i piidi SFUNC kA, EF: Paste(ilh);

AE, SFC1 HHLYE SFUNC JZiXts. ARG, fEnI#5 DA RMT1 2K,

i RMT1 2GRS Plant1 |24

4. SIMATIC Manager ft Plantl EX& @ 7 RMT1 UL, @4k
RMT1(1). 1t 4k, JZ2WEH#£ L CFC ZhfER FC111, LI 111, NP111
Mg 518 1, 4 FC111 48k FC112.

5. FEEENGETETE RMT1(1) 2k &4 50 RMT2;

6. WZGLAIE FRIEL

Old Name New Name
FC 111 FC 211
LI111 LI 211

NP 111 NP211

7. ¥ CFC Dife Bl &4 Fri% FRIE N

Old Name New Name
FC 112 FC 211
L1112 LI 211

NP 112 NP211

T VAN R, BATEAL TR R XA CFC 4

'5‘: COLOR [Plant View] -- CASIEMENS\S TEP7\5 7prof\Color

=[] PLANT1 | P
=16 RMT1
~(g) FC111
B L1
F-{Ba) NF111
1 [B) RMT2
() FC211
B LIZ11
&9 NP2
B SFUNC

iE:
T RER ) TLAHEAZ W] LLAEAS [A) GO ATAS [ D RE T 2 1) 64T, PEAR B 2 WL AR
HETM.

LA 2@ TIH COLOR 1) CFC hfgldl, fEDhfelh, JATEA 726
Be, @BIRES R T 2EL I HACThRER AL . Rl FAiTtesg o 7
% ILIfE

2-8



3 fE MM/ HENIE

Hi N Bh R (Import/Export Assistant, fiiFR IEA)H T4 BRITH (Ab P K B 5dE)
HPOSREAE R B, B Re IR S .

PR (Model) & J2 k4, ‘&4 CFC/SFC Ihfeld, RERIE, W& LB e
o RN B, @ AT E 2 R

B S T AR, A NS S W TR R A, LR 4
Haik.

3.1 EI—EE

BAHEE g —A VALVE(RT )BT RE ], FF A ERANE 1 1] 209 A4
JBHEIE T B
AT AR FErp B H rh g AR D RE ] . AR AL 2 48 m CPU
e, HEAEE I H SR RN SR
BN
TN T AP BRSNS
1. ke Hfr 4 File > New
2. {EXHEHEF, #%$ New Library 35, i A%F COLOR_LIB, fiili OK;
B ILAE Component View #1K] .
EERIINRE T §EE
TR AR ST BT, IFERET LI ] VALVE R D) e
1. fEEviksE COLOR_LIB %;
2. B AR HEE, %+ Insert New Object>S7 Program;
3. H Views>Plant View I£$ Plant View(T.] #iL[&);
4. fEEPINE A, fr4 o PLANTT;

5. Ak PLANT1 2%, H Options>Plant Hierarchy>Customize 7 JT
H 5 X T J2 #5(Customize Plant Hierarchy) %} ifE;

6. & NEWE T JZIKE:

3-1
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Customize Plant Hierarchy

bumber ot bianchglevels 5 =
|

Documarrstion pesfic
~Level Setfings
Level  Mawnumber  Includein ‘with 0% area
of chaacters  demgrabon separator
it 02 F c
2 E= v I3 g
2 = | ] o ‘s
+« [ 3 r F r
e 3 F R
Previens [TV,

¥ Base picturs hiesarchy on the plant hissarchy
I &5 2 R HEAEIE a0 sticr o e G e

_Cawcel | nep |
7. 7€ PLANT1 &N T4, 4 Models, FATK B S i fra i
RYUARAF AR XA T 5
8. 1t Models #4fi A\ VALVE 14, 17Ty,
9. 7F VALVE ¥#:4f N4 4 VALVE ¥ CFC [&;
10. FEWIL) JERan F -

‘Eie Edit Insert PLC View Options Window

Hel =18 x|
D8] & [ms[] sl [5 =] 2

COLOR_LIB WALVE

[=1-(Ea] Plant1

=) [Ba) Models
T VALVE

Press F1 for help. A

L] VALVE #8IThRE
FT9F VALVE R ThREIE, & NG DhRetdy 44

Block type Block name Meaning

CH_DI FB_CLOSE Feedback valve closed

CH_DO QCONTROL Control output at the valve
B

[ EWo Boj

4
wD
o [B0_waLUE_ac | [CoURciTr EY)
o
@
-1

L

BO SUBI_T ak 0o
[CEH_ERF B4

0C | [aman RUT_ Bk
0

FE_CLDIE o (B4 WOOE |
CH_O1 L3 QOFPENED B B0 1T | ouALTTy BY
0 gi kol o [GCLOS WG Lo

El FEM || _QELOSED Bof

dEwD L

o 4

1—{BD_VALUE

o WEZ

~{B0_SUDS_T

UAE I VALVE (¥ CFC Zhig
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AP H i A\ o B B

RN/ B EERY 1/O
h T AT SO /O I TLAHIERE, AR hikd% 1/O:
1. fELJ )P COLOR_LIB () Models % Hik £ VALVE J2 K
2. EFZH 44 Options>Import/Export Assistant>Create/Modify Model;

3. EFHEN KIS, 2 IIiH COLOR K~ I/O:

Block Name | I/O Parameter | Block Type | Remarks
Parameter flagged 1/O¢:
FB_CLOSE SIM_ON CH_DI Default values for
FB_OPEN SIM_ON CH_DI the charts to be
Valve START_SS VALVE imported
Valve MONITOR VALVE
Hicrarchy  Char Block  Block comanment | 190 name 110 comment ﬂl.‘lﬂﬂ Tvpe
Plart1'Wiocel | VA, GOONTA. . Digiel Oulput GUALITY | Gty Cosde: ol g BYTE
Flart 1 Wocel . Vi |Valve  Single DrveDus- . [EN O O N et
Plort1hodel. . VA Vale Single-DriveiDuai- . |W_LOCH | 1=Lock 10 SAYE posii... [ I Im} BoOL
PlartiWodel . VA, Vale  Singlh-OrwaiDua- . [Vi_CPEN | 1=Lock o DPEN Ol O Bo0L
Flart 1 hiocel Vi Yisle Single DraeiDusl. 1#Lock to CLOSE D | D BoOL
Flort{'Wceiel.. VA..Vahe  Singh-OrvelDua-. Ol O Bl
PlartiWodel | VA Vahe  Single-OrwaiDus- . Safe Postion 1=Cpen..| [ | [ BO0L
Plort1hodel. .| VA Vale Single DriveiDuk- .. 1=5iert with Sale Sial. g | D BoOL
Flart{bicdel, V4. |Velve  Singhe DrvelDus.. FALT 55 1-nCesecf Fauki Sa. [ [ BodL
Plart 1 Wodel VA Vabe mwm...lgm Unkabla nput FESET | [ | [ e
Plort1hodel. . VA Vale Single DriveiDugl- . |CSF Corrol System Fauk 1. [ I O BoOL
Plart{Wiodel | VA, [Vahe  Singhe-DewalDus- . FB_OPEN | Fendbiack: 1=CPEN Ol O B00L
Plert1hodel . VA Vale Single DrveiDugh. . |FB_CLOSE Feackack: 1=CLOSE D D BoOL
Flont1Wodel, VA |Vahe  Single-DrweDus- . NO_FB_OP 1-No Fsedback OFEN | [ [ BoOL
Plart Wiodel | VA, [Vahe  Single-OrwaiDusl- . NO_FB_CL 1=o Fesdback CLOS .| [ [] BOOL
Flart 1 hiocel. . Vi Vale Single DrvaiDusl. | MONTOR | Ssiect 1=Wontorng O D BOOL
Flant1'hcsl_ V& Yalve O 0O BCOL
Fartibodal | VA Vale O O G
Flart {hiocel. | VA Vale Ol O BOAL
Flort{'hicdel... V... Vahe Ol O BO9L
Flantihoisl Vb Vahe O O BoOL
Plort 1ol VA Vialve O 0O BoOL
Fart'hodel... | V... Vale Ol O BOGL
PortiWodel VA |Vshe  ShplOeveus- . AUTL | Ueksblepuitor WA [ [] BoOL
Florthiodel. | VA |Vale  SigleDriveiDus-...| TIME_WON | Tierws [3] Ol 0O REAL
Disrd Vlecial (VL sk ShslsPewafial, SAMDUE T | Carede T (1 [ -] C TR
SRIE 1% Next 44241 ;

4. EPIE BN B (Message) i shfEbk. ZTH COLOR, A HI1E B
A, RIAREA AR BSCAR, K512 Next $241;

5. W/ERHATH /0 5 IEA SCHRIESE . DRUWIERA 7 IEA SO, wukds
Create Template File #24f; 7& IEA Cfhrh, 45 Bk EEM /0 A
B, AT REE LI, S0k A3 1/0.

6. L5 ST A N SO — AN ST (B AT 4 S 44 Import00.1EA):
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A5 g A\ B

7. AEAEAE | I R

For CFC charts For messages
™ Function designation  [FKZ) [ Info taxt lInfoText]
; Location designation  [0KZ) ™ Messagetest 1 [MagText)
Chail name [ChName]
PET, ol | e e
I Black comment [BleckComment]
™ Message texl 4 (MsgTextd)
_g' ¥l andi .w_‘ . [~ Message 1t 5 [MagTexis)
r Flafe;ermname IBelN.aml ™ Meszage test £ [MsgTexts)
¥ |[Freraceneation (Epmtei e ™ Message lest 7 MegTent?)
™ Symbol comment [SymbolCerrren] I~ Message text 8 [MzoTextd)
I Absoluie acdiess [absAdd] ™ Message lewt 9 [MsgTextd)
;’Ti:nc‘";?ﬂ‘“ gﬂmﬂ ™ Message et 10 (MsgTest10)
Ui [57_unit)
F TedD (57_sting_D)
b Test1 [S7_sting 1)

ot | _wp_|

RJe rih OK %41, [EA SR Bicss Valve FALDIRER;
8. wiili Open File ¥, 7€ IEA SRR N EFTHIE KL

i
7 [EA U, w1 Edit>Duplicate Row i & 52117

I IEA Editor Edit IEA Files - C\SIEMENS\STEPT\S TmoiColor\lmport ). 1E A
Fie Edl View Window Help

D @&@]| #[]®] || 4] Albl41%] =] ¥ =

FE CASIEMENS\S TEPTAS Tpeof\Calar\mport 00 IEA

| S Chitane | Ve alue Ve Vabse| ST_stringl | ST_stringe
Chart FB_CLOSE SM_CM | FB_CPEN.SIM_ON | Yalbve START S5 | el e MOMTOR
H a 2] L] 2] | H

FLANT? RMTT 1K1 110 €171 Sicp vabeet tarkd |1 I a [0 monitcrng=0n Mardonng=0it

E FLANTYRMTT 1kt 120 M¢112  Siopvabee2 tarkd |1 | i 0 Meororing=0n Markanng=0ff
B |FLanTrAMT N 1R Mic113  Stop vabadmanid |1 | 1 Io Morrierng=0n  MarkarngeOf
[PLANTMT 1] 141 114 Sicp vabed tarkl |1 " 1 e Morioring=0n Marnkaring=04
FLANTTRMT FZT1L 211 Stop vailed tark2 |1 il ] o Mororng=0n Mankanng=0tt
ANT1EMT i TG Sop vabeZtankd [1 e I C] 67 Mertioring=Cn Markarng=Gif

10 L N3 Slop vabeed tank2 |1 " 1 0 Morflofing=0n | Mondornng=0ff
lEﬁL}mn‘ﬁMhM:n' B T e O in i [ Worfrigecn orkang-07

9. IR IAMIFRE . 1] File>Save As 4, ¥ IEA SCHEAEEE H
5k: Siemens\Step7 \S7proj\COLOR, 4R )& <k 3.

Impoit/E sport Assislant. Creste/Modily Medel - COLDR_LIB\Plant1\Models\WALVEY

ot clsta o o assign {0 which model data 7 154

Dthes Fie

Dpen Fila
Cresle Tamplste Fils

Chart Block | 110 name L0 garmamant 10 Typa Mase no.
- [VALVE FB_CLOSE[SIM M Swiich Ob 1=Siuist. LT BOCL
. |[VALVE FE_OPEN [SM_0N  Swiich OM 1=Sanust | |NOUT BOOL |
. [VALVE  vawe  |START_SG 1-Giart wihSnte St N BOOL|
L VALVE  Vawe  [MORITOR Select T-Morkorig 0. N BOCL|




AP H i A\ o B B

wpart|
X which e P ) @
| o file: |r ASIEMENS\STEPTAS TibsC okor_Mlmpont 02 IEA Dithes Fil=
1= | Croctirenl Cev fonchan el Kave Upen Fis
Craste Tomplata Pl |
Niwpeot cal: Moded dala:
. . Hierarchy Chart Block 10 name V0 comment 0 Type Messno.
P |FB_CLOSE S O [Plantiitodal . |VALYVE FE_CLOSE S _ON | Swiich ON: 1=Simulat .. INOUT BOOL|
P |Fo ceimem on Pareitaodel [VALVE  FB_OPEN (SN 0N |SwichON: 1=Snust . INOUT BOOL
P [Vare START 55 |Mankibiodel. [VALVE |vave ETART_SS |1 =Start with Sate Stet.. N BOOL|
P _n-ﬂumn..'vuve [vmve CMTOR |Select Teborfioring O JN | BOOL|
=
N R ap \ =0 N N N e AL
M. AT@EIIAER, &+ VALVE ZXEG, RiEEHEX G LS

12.
13.

14.
15.

16.
17.

Options>Import/Export Assistant>lmport; K% S 27 FEhik# T
MR, PRI E e WIS HREIH RS PR
fF Step 1, il Next %4,
7£ Step2, #F% Find Target Project %4, #kJ5i%+¢ COLOR i H, s
i OK; sl Next;  3X—205) T-HOUBAYHE D BIF I H & 20
¥ OK ¥4 M 15 K. Find Import Files;
E Step3, siili Other File #4H, LM Import00.IEA, Hii AL
PR 3 Bz I H HORE Y, SRJE e FE Next 124 ;
1F Step4, i Finish 151, JTFa%N;

NTERUG, il ExitGREFHL: BEi, VALVE JZIRGERER T JR2IR
SRR TSIl S] AR A

-
AN, 6HEHEER{E S The hierachy folder is not yet assigned to a chart

folder, do you want to make the assignment now? , £+ YES #%41l, /rlcss
11 ThRE I3 SIMATIC400(1)\CPU416-2DP\ S7 Program(1)\Charts.

HE‘.IHATIE Manager - [COLOR_LIB (Plant View) -- C:A\SIEMENS__. =] E3

‘Eia Edit Inset PLC Wiew Options Window Help

DIS(22|] 5|l da] [ 2] o[
= 4 FGEG
- [E Models
&3 vaLve
Press F1 for help. A




A6 FH i\ L B 2

'—:ﬂ‘ COLOR (Plant View) -- C:\SIEMENS\STEP7\S7proj\Color

= &P COLOR
= () PLANTY
EE Models
=-[E) AMT1
(& FC111

: () L1111
| @ e NK111
| B NK112
e NK113
| &) NK114
(@ NPT
=23 FE
| (B FC211
- E-{E) LIZ1
| B ) NK211
| @ e NK212
| E e NK213

M @) NK214
| @ (B NP2
- SFUNC

| FC211
e NK211

& NK214

(EaL1211
[@)NK212

&I NF21T
@) NK213

WiH COLOR v, fEANEMEHIN, £ RMT1 F1 RMT2 ZE G447 Bl
T, BIPNKT11 2 NK114, NK211 3 NK214.

AEFEEA ] T A N et BO B, 4R T IhBE /O, AT IEA 3. i

LA f A\ D RE

FeAl7E X A8 RTM1 Rl RTM2 &7 7 Dh e VALVE & 4615
B CFC IhfEE:, B Rhia e S B A &R .



4 {£H SFC “migss

SFC 23R8I Dfig ¥l (Sequential Function Chart), i AR HAT
IR & UM, BHARZENIREHEE RS —IRE.
SFC HARIFE v LS HADIE 5 A AR RN AT AN Hl g .
ARFE S g sr. SFC DhRell, Wil S HE s licssy CFC Dhae T izhae
B,

4.1 M7 SFC BS54

TR R N EANBIREHN, RATC2% SFC Uigel# SFC1 # %] SFUNC
EAE . BAE, AN DR A4

1. 7E SIMATIC Manager i%# SFUNC |2 %45

2. M8k SFC1, %4+ Object Properties;

3. ¥#% SFC_RMT1, g OK.

4.2 |FEH| R G

I

{EH SFC ZmdE g%, Tl LLEE 3N T RE I AR Fh 4544 .
o  XGHFTIF SFC ThfeE SFC_RMT1, #EA SFC 4iiEae,

Rl Ky o2 B et th e &, & HUA & W 22 (START A1 END) K — A5 8 4% 1
(transition).

#(Step)s24E PLC AALHR /ML A RAE (Action) I AL, e — B T, HE
AR AR .

TER D ST D, AL, St e b e TR i
i

1. RSB &R =

AN N7 (=R et N e ) | R S - S 2 1 e =5 W N e 2 Bt
PAVHEAZ DHREMALER, RS Bl R, WS EdRr %R
AR 2477 .

2. B MNER FMIREARA B Z0F 1 N s, middiblbe, 20 3 M4
2 Beddi N

3. milHEAS T Bl

4-1



1411 SFC gt %

4-2

4.

5.
6.

7

Bal/h7Oouhr®] START R J7, sdadiblhn, 22SZgddN, [, HBa
3 A4 A HES) A F I BAEL 4 (R TT s

TEPEAT NN RS 25 A 5

TERRS 20T 3 A0 4 IR 0 i N % DRE, 2 b A1 6 JHFeAs 261t b A 6 Y
N

TERR 20T 2 KRSt IhBE, 20 7 MBS A0T 7 il

BUAER) SFC &kt h -




] SFC St 4%

4.3 f &+ (Step)FniE B &4 (Transition)

AR AR VAR

1. %F% Select #2410 ;

2. MR 4&AF 3;

3. EXNZIEYER General &, ¥4 78 DOSE_REAT,

4. fidi Apply #4240

5. THE Fili MR &L, A i A,
Default Name New Name
5 INIT_1_OK
1 INIT_OK
2 END_DOSE
7 CLOSE_OK
4 DOSE_REA2
6 INIT_2_0OK

6. ATIAEA, THRELAT 5o KUK S HB AT HLUT

7. 1% CLOSE %4 el x5 s MEXT A

Default Name New Name

5 INIT_LINE1

4 INIT_DOSE

3 SLOW_DOWN
7 CLOSE_LINE
6 INIT_LINE2

8. AT MR VE ST AT iR, 4% RAK I 44 -

A 5E UG ) SFC DhRekl A

4-3




] SFC it 4%

4-4

I'l SE_REAT

INIT_LINE1 IMIT_LINEZ

1

Vitd
iy,

1.
2.

5.
6.

INI’T 10K

INIT_DOSE

| L

SLOW_DOWN

l END_DOSE

CLOSE_LINE

SFC i asrh, #al LIS EE Rl CFC ThEes N . £ START
B B ORI RE R

it START 0,

EXRBIET, EF Initialization £, EKERTR LR, Sbed
%ﬁﬁz

i Browse, FTITAFEHE, Bl 7Ex iEHE @ iR . Beil, CFC Thg
K RMEFT T, 3 b s TiZ 0 H il BT CFC Zhig

. Riids CFC ZjgElE FC111, FIJFEE ki, B3 FC111 W4 HIhae

B
s P Crl Dhfgdk, FTIFZIIBEDLR) 1/O 5 5
Mt AR B AUT_ LT AT BRARHS S 844 K81 n ) ;

Browse X iGHEIR B i, SELEFERBRARAE N 55— ATHIZE — LIS ;

7.

SRJE, JCHRAESE —HITPINER, FEBLRIA 0, RO T —AT,



] SFC St 4%

BT Initialization X7 Bt -

Gereral Inihalization |Execuh0n| Termmationl

1 |[ModeRvALVEFB_CLOSE EN = [FaLse ﬂ
_z2 | =

L2 JF] ]

4= -
5|
_E e
el |54
= |f]
_o e
o |F =

LCloze I Apply |ﬂﬂﬂﬂ Frint I Browsze. . I |Ejoirs) I Help I

8. miihi Apply, 5ERk Start LI E ;s AR a4 FRUIKRAE H 4 id .
FIBBOCH AN RN 28, (HRA1E Apply %41, SFC ZwfH 4544 1 )
TORAN SCB T RIS, BRI Yes.

R R E B AR (Action), b T W AIEINN (A, BT A IR AE Gy & AR AE
Initialization 432 HHAT .



{1 SFC St 4%

Action/Tra |Address 1 Opera |Address 2 Meaning
nsition tor
START RMTTN\FC111\Ctr. AUT_L = FALSE Manual controller

RMT1WFCT11\Ctrl.SP

RMT1\LITTT\PARA
_DOS_RM1_QTY.V

Setpoint flow control

RMT1\FC111\Ctrl.LMN_SEL = FALSE No correction
RMT1WFC111\DOSE.L_START = FALSE Dosing stopped
RMTT\FCT11\NT_P.TRACK = TRUE Correct integrator
RMTT\FCT11\DOSE.SPEXT_ON |:= TRUE External setpoint
RMTTWRMTN\LITT1.INT_P.TRACK |:= TRUE Correct integrator
RMTT\RMTNLITT1.INT_P.HOLD |:= FALSE Retain output value
RMT1\WNK111\Valve AUT_ON_OP |:= AUTO Automatic mode
RMT1\NK112\Valve. AUT_ON_OP |:= AUTO Automatic mode
RMT1\NK113\Valve. AUT_ON_OP |:= AUTO Automatic mode
RMT1\NK114\Valve. AUT_ON_OP |:= AUTO Automatic mode
RMT1\WNP111\Motor. AUT_ON_OP |:= AUTO Automatic mode

INIT_LINE [RMT1\NK111\Valve. AUTO-OC = TRUE Open valve

1 RMT1\NK112\Valve. AUTO_OC = TRUE Open valve
RMTT\NK113\Walve. AUTO_OC = TRUE Open valve
RMT1\WNP111\Motor. AUTO_ON = TRUE Turn on motor
RMTT1WNP111\CH_DI.SIM_| = TRUE Simulation:

Simulate value

INIT_LINE [RMT1\NK111\Valve. AUTO-OC = TRUE Open valve

2 RMTT\NK112\Valve. AUTO_OC = TRUE Open valve
RMT1\NK114\Valve. AUTO_OC = TRUE Open valve
RMT1\NP111\Motor. AUTO_ON = TRUE Turn on motor
RMT1WNP111\CH_DI.SIM_| = TRUE Simulation:

Simulate value

4-6




] SFC St 4%

Action/Tra |Address 1 Opera |Address 2 Meaning
nsition tor
INIT_DOS |RMTIWFCT11\Ctrl_PID.SP_EXT |:= RMT1\LIT11\PARA_ |Active setpoint for

E DOS_RM1_QTY.V flow control
RMTTN\FC11N\Ctrl_PID.AUT_L = TRUE Controller to automatic
RMT1WFC111\DOSE.SP_EXT = RMTT\LIT11\PARA_ |[Active setpoint for

DOS_RM1_VOL.V dosing volume
RMTIWFC11N\DOSE.L_START = TRUE Start dosing
RMTTWFCT11\NT_P.TRACK = FALSE No correction for
integrator
RMTIWFCT11\CH.AI.SIM_V = 50.0 Simulation:Flow 50
Liters/Min simulated!
RMTT\LITT1.INT_P.TRACK = FALSE Track integrator
Set the minimum run time of this step to “4s”(Properties/General)

SLOW_D | RMTT\FCT1N\Ctrl_PID.SP_EXT |:= 10.0 Reduction of the flow

OWN setpoint
RMTIWFCT11\CH_ALSIM_V = 10.0 Simulation:Flow 10

Liters/Min simulated!

CLOSE_LI RMT1T\NK111\Valve. AUTO-OC = FALSE Close valve

NE RMT1\NK112\Valve. AUTO_OC = FALSE Close valve
RMT1\NK113\Valve. AUTO_OC = FALSE Close valve
RMT1\NK114\Valve. AUTO_OC = FALSE Close valve
RMT1\NP111\Motor. AUTO_ON |:= FALSE Turn off motor
RMTTWFCT1N\Ctrl_PID.LMN_SEL |:= TRUE Correct  manipulated

variable to O(close
valve)
RMTT\FCT11\Ctrl_PID.SP_EXT = 0.0 Active setpoin for flow
control
RMTT\FCT11\Ctrl_PID.AUT_L = FALSE Controller manual
mode
RMTT\FC111\DOSE.L_START = FALSE Dosing stopped
RMTIWFCT11\CH_ALSIM_V = 0.0 Simulation:Flow 0
liters/min simulated!
RMTTW\RMTNLIT11.INT_P.HOLD |:= TRUE Track integrator

4-7



{1 SFC St 4%

Action/Tra |Address 1 Operator | Address 2 Meaning

nsition

END" RMT1WFC111\Ctrl_PID.AUT_L = FALSE Reset input
RMT1TW\FC111\Ctrl_PID.LMN_SEL |:= FALSEE No correction of

manipulated variable

RMT1WNK111\WValve AUTO_OC = FALSE Open valve
RMT1\NK112\WValve AUTO_OC = FALSE Open valve
RMTT\NK113Walve. AUTO_OC = FALSE Open valve
RMTT\NK114\WValve AUTO_OC = FALSE Open valve
RMTT\WNP111\Motor AUTO_ON = FALSE Turn on motor
RMTT\WNP111\CH_DI.SIM_ FALSE Simulation:Switch

channel driver to
simulation

-
E:

%Jllﬁ}?‘?%%quﬂ:’ END TBTEE'T/E/E\Z%ET)&L?IO

AT END $#84ERE A7

DRI, R 2 RS AP S BE B 1) A

SFC Thfe D CaAT il BN S, AP #AT SR DU K BB (AR B &

K)o WIEHAR B, EARIES PR RIS

4.5 TENFEBFH

4-8

e 4 (transition) & & PN — L H A B R — D 1 44F, LS Hh I

LIS IR

1. WA 444 DOSE_REA1;
2. & Condition KT, ZRIE ST EALET, JohrrER AT INER:

3. Hiili Browse;

o N o o1 b~

7t CFC Charts £, siifi LI 111 Dhfg
s gtk PARA_DOS_RM1_SEL;
At QO, iy H R N BN R AR R AT
TESE A NBRAERS 1, 4% Tab
midi Apply, A RIIEERE ST -




] SFC St 4%

Properties - 1 -- COLOR_LIB\ModelsA\\WSFC1 I
Geneal  Condifon I 05 cummenll
1 [MedelsalvEwave sUT L |- =][TRUE
i | [ =
3 =1 &=
: =]
I | [ = L
| [ =l
| [ = &
| [ = &
&l j —
10 =1 +
Lloge I Apply |ﬂﬂﬂj Eiint | Browse... I |Eielre] I Help |

FR RN 50 DOSE_REAT B E AL B R 26 I 25 1
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{1 SFC St 4%

Transition Address 1 Oper |Address 2 Meaning
ator

DOSE_REA1 RMT1\LITTT\PARA_DOS_ |= TRUE Dosing reactor 1?
RM1_SEL.QO
RMT1\LIT1T1\PARA_DOS_ | > 0.0 Dosing volume higher than 0?
RM1_VOL.V
RMTI\LITTI\MEAS_MON | = FALSE Container not empty?
.QL_ALM

INIT_1_OK RMT1\NP111\Motor.QRUN | = TRUE Is motor on?
RMTTN\FCT1N\Ctrl_PID.QS |= TRUE Is controller switched to
PEXTON external setpoint?

DOSE_REA2 RMTIWLITTIWPARA_DOS_ |= FALSE Dosing reactor 2?
RM1_SEL.QO
RMT1\LITT11\PARA_DOS_ |> 0.0 Dosing volume higher than 0?
RM1_VOL.V
RMTT\LITTT\MEAS_MON. | = FALSE Container not empty?
QL_ALM

INIT_2_0OK RMT1\NP111\Motor.QRUN| = TRUE Is motor on?
RMTTN\FCT11N\Ctrl_PID.QS |= TRUE Is controller switched to
PEXTON external setpoint

INIT_OK RMT1WFCT111\DOSE.QST |= TRUE Dosing started?
RTDOS
RMTIWFCT111\DOSE.ER |< 500.0 Dosing volume:

Setpoint-Actual Value
<500 Liters?

END_DOSE RMT1WFCT111\DOSE.QST |= FALSE Dosing ended?
RTDOS

CLOSE-OK RMT1WNP111\Motor.QRUN |=  |FALSE s motor off?

AbER G

4-10

fANSERn, SFC UM T .

SFC Ihfg K% NPT
START B

DOSE_REA1
DOSE_REA2

5L )

— WA MCRHE IS F-8)(manual)
— DI EORHE ) 8 Ah i (external)
— {5 1Bk
— A RN 1 BN 2 ?
— JRURHGE 5 217




] SFC St 4%

INIT_LINET 477 — FTFFAH R I
INIT_LINE2 — JAZ)E

— BRI A D4 2SN
INIT_1_OK  %E] — I RIBAT?
INIT_2_OK — RSB E AN e ?
INIT_DOSE =il — FRE OB 45 e

— BB BCRHE SIS N A 3)

— FRE BB e

— JFAABCR}
INIT_OK B n) — BB T

— Bk (45 (E - 4 HT{E) < 500 Jt ?
SLOW_DOWN #4l — FEENABRBCRME LAFT, &8 AR R

U

END_DOSE %t — BB ERE T g ?
CLOSE_LINE  #:6l — KPR

— R fFE BT

— WMz I3 D14k F-3)

— WEBKEHEE N 0

— {5 R
CLOSE_OK %k — FE A ILIEAT T g ?
END =212 — V)R A8 A A g e

— KHIHT)

— HHUFIRIEAT

ERTESRAT Rk R 3l A AT AL ) SFC Zhigl .
ARE, RATCEE TIUFHERI RS WM&, BATE S 5
Fogs 7 CFC DRER, AL T U2 R g8 5 SR I Dh RE I KR 3R






5 #wi¥, TEA&MIK

RS AU G PRI AL CFC Ml SFC 27, Wil RE e FAEIHlRs,
AEAT OF BATRE Y, DUMER &R 2 1 e LA

5.1 miFEHIIERF

TP L RR P 2 G BE R AT PAT LA R 5, HP IR

1. 47T SFC Gifias, itttz 6]

2. TEFTIFRORHERES, ridh OK, ZWiedsrandn PR (645 487 S7 Program
(147 CFC/SFC Thfield). gmiesehi)m, #3esive, K HIl T idfE R
Code generator: 0 errors and 0 warning(s) found

3. % OK ¥4, izl B

E RIS EL S Empty OB1 was deleted fid %% 1, Al
Close RMiZE M.

5.2 T##iEFF CPU

e WNIRAETFAR I & IR, TS, S WA S k.
NEGHIL T PR EO T RS, AR5 T4 CFC/SFC ThRelsl. iR
AHUBTEIH n) 5 @57

TEEMHATS
TR AR IRWT
1. D)3 SIMATIC Manager & H;

2. 73 H COLOR ) Jt 4 # &l (Component View) ' X i SIMATIC-400
Station;

e g 1 rp Xt Hardware;

A Download to Module 41 6| :

% OK #% 4] Select Target Module X} 5z ;

i OK 14 Select Node Address % ifiE;

HEL—ASGHEHE, 35 UFEE CPU A T 1R A, ¢ YES 4240

. CPU Ja33), CPU Mtk izt LED #8747 RUN fi5Es

HS% 54 Station>Exit SCPIBEFALRS, T B 2H A I3 52 5

o N oo o0 b~ W

5-1



ik, PR

THIERF

A7 CPU LR AL T STOP 5 RUN-P A2 &I 4t PR, A THIE N

BARENREFIS CPU Hh A DR, T RREFP R HRLIAE STOP A&, #or

AH e EE:.

1. ¥ CPU Jfft RUN-P i &

2. V¥ SFC Dyl SFC_RMT1 & 1

3. ik Rk |8] , 13 S7 Download %fifiliE, ¥ Entire Program i
Tt

4. 5 OK, HILAN R XHEAE:

Download [13:4352) E

The module iz in RUN mode.
Do you want to switch the module to STOP now?

No Help |

PATTRHE S RIS, 7 B R BN B 48, 2l CPU 4T STOP J7

o HAE R Al A PrAT D RE DR M BR . A5 42l Db T STOP

Jias X IRHE R VR INBRPT A ThRg b

6. st YES #%Hl, TG FERPERERIG: FEGEME, AR R
JRshizE il gs,

6. LHE YES 4

5.3 IR ENIXR

M3k SFC

i CFC

5-2

IAE, EANMAAE, R T 07 B0

1. 76 SFC guitaety, rahuutinman B, mm At T A K.
EDIRER BRI PUASEE S, i Command Output S 30T s

2. H3EHdr4 Test > Start/Resume Pl 745 24021 Continue, SFC Ij
Fe B 0

YHTCAPATIE LIRS RN, — AN S B Sk IR %P 155100

SAFBAT WS RS S A LA B S s

MRS FE R, EnT AT DRI R 451, 1608 T UR 8 42 P56 B I S 40U

el AR

BRI, S5 TTF £ CFC ShAEREl P ThREb. $fi 5080 T .
1. BEA SIMATIC Manager % I, $TJF CFC Bhfg/E FC111;



ik, PR

2.

1 CFC g, aiehllalBie% g |

FEDIRED N VO HIRL I, T AEBCRE DI RE A 222 B 2 i
N TR R, 4% T D BRI A

1.
2. Ml CFC 4ikas:
3.

4. prt AR IR (8] . R,

5

bR RE 8], BRI E
Yl 3] SFC St e

KM CFC gk 5

AFERATE ) T U PRy, AR RE Y TR s, DAS A oy e 1
AT

5-3






6 {ERHFIERY

FERRAE Bl b, T EUETEAR R D7 S A L Ry o n] o 21 J5ORLREF)

VLTI, BT A7 RS SR AE B AR Dt b, ] o

6.1 IR LEE

ABrh, EERIRS SRR G DL MPI RZERE . O T @R, i N R
1. 7E SIMATIC Manager "', #EATGHHLE (Component View), L+
SIMATIC-400 Station(1);
2. ELME ONH Hardware, Ja iR, Bon s dlss a4,
TENE, 18 W I R AR I S5
TR b0 8 1 I 4 5 1A Dot LA 4 07 e
3. Xili CPU 416-2DP, #]JT /@ PEXHHEHE;
4. 7t General £, xiii Properties 4% ;
5. {F Parameter & L[] subnet HE, £ MPI(1)R4%;
6. % OK B OGNS 1hHE
7. ik T [
8. 1% OK # X4 Select Target Module X} ifHE;
9. #% OK f#%H] Select Node Address X} 1A ;
10, —ASBIOREHE S M, S Ids a2t T3 IERAS, AR MR,
Rty OK %4
WA R s n, SIEHE S RIS Bl A A T RS
11. E$E YES #2581, #RHIZS ATk Frsgts RUN $RRAT A%,
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6.2 EIF(ERIEAIEREE

PCS 7 MIHAE Dok L5 1 Ar AL i T 1) SE PR Y H B ¥ . f84F Base
Data "W S @ A¥dE. 7 Split Screen Wizard 1, g s
PCS 7 KB RGN Bor o HER A BE A Jrys AR W Frh, SERUE B 0K
(Message) % &

1. f£ SIMATIC Manager & 11, H EbsA g sl OS,

i%F$£ Open Object;

7E3 H H 3% & 1 1% Base Data 15;

A5t S Split Screen Wizard, %3 Open;

WP EHRL PN 1024X768, Al Next 144

Bz WoR A A BB (> CRT), sy Next 4%

7. BRSO HIERRCER S, S Finish 2

WRERCFHH, SIS H TASEIA R, WTRARREL, % OK #

KA H R AT

% /N 1 Split Screen Wizard — Generation #5447 J7: 245 Thagse s, ¥

b=~ KR A bR s

DR EARE RIS, BER FIR{EE: The display data has been

completely created/updated,

8. F% OK B G 1EAE ;

9. AN Alarm Logging Wizard, i%£#% Open;

10, 2B N FHERCE, IR Next %41, SRJ51% Finish #4241
WREDCFRE, HFEHTHASERA 2 TRARRGEE, %
OK BEICH] B TEPAT
5 ANE O Message Wizard — Generation 377, #(4T7F; 4HThiE
e, B B AN R A bR
P Dhaemi tbn S UG, # 278 Fid(5EE: Generation finished. All
steps were carried out without error,

11, Ubi, i OK BEOCHIXNEHE; BIBLAE A 1L, PCS 7 T H #HAE Sl A
Bm(staeAi . RGO, IRESE) A EE.

D 01~ WN
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6.3 ZEIIFFAF

TATAT LABZAUAS R 7 (User, BI#AE 53) n] DABRAR B JE IR 7R . AR R I H 1k
M, ZERrLL i P A e D g, AR, AT e N B A —ANET
Fe

1. fEWHPHE N, A8 54 User Administrator, %+ Open;

A8 it Administrtor Group, %% Add User;

FEFTIF RIS UGHE S, A AR A 4

F OK BHEOCHIXNUGHE . GG kAT, nl AZBUZH P Bv5 i AR,
A SUARVT V7 ) S

7t Authorization FIXGEHEEHE, LA DI6E, RIERTH T Dhfes

6. FHSEHH % File > Exit S & #L A 1

A WN

o1

6.4 EHIEEFE

ERAE SR T8 1) W PPIRES, B By DU N1 H ok

7t Plant Hierarchy ™2 RAGENFISREE [, 0204 7 Be g Bk o1 ik (s

2RI G PR), SR T Sl A N R k.

T IF R, SaEFIF) Graphics Designer & 14 A 75 Z 11 5 &A1

HAEIEITE .

1. YJ#e3] SIMATIC Manager % I

2. BEATH ) Plant Hierarchy % 1 ;

3. ¥EFERMT1 %, sidifit, % Insert New Object > Picture, ffiA\Hi
T I T

4. ¥R s 448 RMT1;

5. Xhpradt s, FTFEE % T Graphics Designer) % 1

6-3
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6.5 (FAERES TSR (Object)

6-4

1. H3EHar4 View > Library #1797 K
B T RPN ERS E T HES R KB

Element Path in the Library

Tank Global Library/Plant Elements/Tanks/Tank4

Pipe Global library/Plant Elements/pipe-user objects/3D pipe horizontal
Pipe Global library/Plant Elements/-user objects/3D pipe vertical

Pipe Global library/Plant Elements/Pipe user objects/3D pipe elbow 2
Pipe Global library/user objects/pipe user objects/3D pipe elbow
Valves Global library/symbol/valves/30

2. HEEEE R AALE, AERdn R

I:l&l:‘l

a

%

R, BRI,
| ¥4 ArrangesRotate HEH: I TEIE 20 .
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6.6 ZEILMEITERESER

BN R IR AR PIRS BN, ARG TE RMTT BB, e B 830w ]
ThReH QOPENED %%

Altarnative 0 N Color: red
> Color

BVREE RS AWL: B0, LRI KR E LS BN S
(symbol); %2, 7 RMT1 BB AHARRS R
ARBRTHES

1. FEEEEITELH, H File > New @75 KB, H File > Save As 25301t
fir44 4 Status.PDL: ] Polygon(ZiUK) LK ThEEEIRA O HIFSRT
T EXGH P IERZ AT, R EIE, X g A
R TR, HE OO B AR 20,

2. H Edit > Duplicate iy 2#5 VIAZRE O AT, BBt s gkt

3. H— At‘i?iﬁz‘i*ﬁt’g‘ﬁii‘ 0 K, H Group(FIf)mr ¥ 44146, H
File > Export @4 ¥ EJEH 2 — 4 EMF #& X1 30fF, skl
valve_v1_h_0, EIJHHI] WA 1, ACPALE, SRR 05

4. H— At‘i?iﬁz‘i*ﬁ’g‘ﬂii‘1 KT, H Group($I ) a2 ka2 414, H
File > Export fn4 KB H B —A EMF &0, e N
valve v1_h_1, EIJI!HI] FRAS 1, AKCPALE, SRR 1;

5. £ RMT1 K, FATi EAEAE SR EE. T @ EEHNE
}1:/’

6. HHATIRES 0 EIE, HIZEHar4 Arrange > Rotate 4 JETiE: 90 &
3

7. HFEFEEERASFRE 1 EE;

8. H3rk4 valve_v1 v 0 i valve_v1 v 1 % 3E B R

iE:
R R BRI — ), BRI

6-5
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HEBRERR
1. F Window ¢ dr 22k PR FRim i RMT1.PDL, 4RJ57E object palette/smart
objects % Status Display (IR W7R) % 4 ;
FEIRES 7~ 0 G i T3 2 P TR v ) o
1EE 44T IT ) Status Display Configuration 7 [, L ehibras il W4 =P
TEFRBEN S 1, riili ES Ky AEHE, SRJ5 riili Update button 4%4

i Tags - Project: C:ASIEMENSAS TEPAAS FproAColotvwincpro O S[1 5051 ). HMCP

Finerﬁ j
5. BPREE /NS5 DREEI NK111 [ ] DR QOPENED 2 %04 #z;

WES
Diata souree: [L3!8p7 Spmmbole
=

fi-E: AMT1/LITTT/RARA_DOS_RM1_GT ] | Nama [ T Q|

- E: AMTIAUT11/PARA_DOS_FM1_SEL [ ZJAUT_ON_OP  BinaeVarable

M E RMT1/A111/FARA_DOS_RMI_VOL | Zys7ep no Vorzsicheniosar

o B AMTTMKIT AVabve T Wotzsicharloea:

#- B RMTTMET1ZVave ZIGERR Binare Varisble

Bh-E: AMTIMKI13Mave ZIGMON_ERR  BinareVanisbls

i E ::H”:ﬁ:}:i‘:’e CJAMAN_AUT  Binars Variabls

i" E HMIZr'l'LZZ'I'I-"L'II‘I o ZjqoP_oP Bmnare Vanahle

E ] - )

- E: AMT2/FC211/Dose —JacLoe GLL LD

. E AMTZAUZ1T /U ZJQAUTOP Binara Vanshls

e E RMT2AIZI/FARA_DOS_RK1_Gr— | GHANOP pmatejianane

#-E AMI2MIZN /FARA_DOS_AMI_SEL  [SIHOPENING — Binare Varistle

- E: RMT2ML211/FARA_DOS_RM1_VOL Bnare \Vanable

M- B AMT2MEZ Nalve - :.]JLLUEJINL- Binare \Vanahle —
i | » —JaCLOSED Binare \ariabls =

0K | Abbescken | Hifs ]

PR BoR AR EHED i Add 12481, RS B RGNk 1
SRR L HPIRE 0 0 HE 3 valve_v1_v_0, AR 1 70 lescft valve_
VI_V_TONEITE S s JAE S0, A SEA &A1 L)

Status Display Configuration [ 2] %]
Tag [RMTTPHETTT/NRTT b COPERE ~Preview
Update IE s ;I
Pus | Gundhid | Blinkbld | Blrkandbat |
il valve_vl_v 0. kein Blinken
1 vabve_wl_w 1 kein Blinken

~ Selection of Picturs

(Ewierezeug brmp
MesssielleMame.bmp
Sammelinzeige bmp
wahe_v1_h_0emf
wale_v1_h_1.emf
vahvs w1 v 0emf

<

Browse

Bit position |0 _l

Cancel
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8. F% OK B HIIRA B /RAR;

9. VHEEIR IO E BIGET I BUE I

10. HHPRA B85 % (Edit > Duplicate), A4 S BI04, d$e
Configuration Dialog;

M. BREERNEYE RMT1/NK112/Valve/QOPENED i#%E4%, 4R )5 X%
HE;

12. FL, #ESPANACFRIASE Baad i) NK113 1 NK114;
13. & FREIER:

Valve Name Tag in the Tag Browser
NK 113 RMT1/NK113/Valve/QOPENED
NK 114 RMT1/NK114/Valve/QOPENED

14, BN AR BoRFF 5051, EEE Status.PDL 1452 NP111 s
AR B A % (pump_v1_v_0 F1 pump_v1_v_1), & 7752 3 pd f
ZILEE T,

Alternative 0 . Color: red

Alternative 1 Color: green

15. P)#3) RMT1 D F2 T, 44752 NP111 @30S BN,

16. fFHFRZEN WSS, BEIPRESE A% 5 MOTOR Thagd: NP111 %
QRUN #:#;

WAE, BATCELE T T ERFPIRES B RS G a] 34T H vp Al I8 E

Status.PDL i [fi -H & 37 A% BonEE

6-7
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6.7 ¥ 1/0 15

6-8

T HERURHRAEREA T, BTG ZEAEIUH sy 1/0 Bk, HDBRATE

1.
2.
3.

LEX % H 3% (Object Palette)f) Smart Objects Hi%#% I/0 Field;
TEM ] FC111 BT —AN 11O 3

¥iZ /0 15 CTRL_PID Zhfigd: RMT1/FC111/Ctrl 1% LMNR_IN %
B2, DMEAEISAT I WP T B 5

4. FERJT] NK112 BHEEES.— 170 1,

5 OP_D Ihfes: RMT1_LI 111_PARA_RM1_SEL HIZ% 10 %4, HTE
BB B R N 2E 1 B 2(1E 8 1 ECEI B N SR 1, A 0 IR RN SR
2);

RIGHCE /O BIMBI . A8 rith /O 1k, 1EFf Properties;

7. 7 Color &1, 475Xl Background Color il Border Color 45 Il i) B (7,

B, REEEAR A HAR

8. KMIX % )& (Object Properties) X} iHHE;

11.
12.

FHTFRERAE AR 55 A 1O BB s

S N A 19 S i 97 o 19 O R 0/ i i1 s W )

Sz /O R, PR S, %R Output/input, Wi Data Format
RS, KA U SO —HE.

K MIXT % JE 7 (Object Properties) X} 15 HE;

AT N SR OB B (4 R R A S B () O R i CU ), RN 2
wbE oy s A 10 B, ¥ S o E % RMTIL
111/PARA_DOS_RM1_VOL .U ##z, ¥ Ui 54% RMT1/FC111/
Dose .PV_OUT #:#%.

/O S fyRAs B g =R, T PATT S DA B R BB (5000 T,
PRI 2 L5 AR 17O 35 T Jesd 1Pk

1.

a M WON

B ShEEER 1/O 1,

% Properties;

EAME D, X Output Format, E#¢4 ks =k 9999;
U G PR T AE 5

FHFIFE D SR SO M HELIR 1/O 3 27 2
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6.8 FHNILAI

SCASIR AL T2 % 5 (Object) brit 44 Bk, I T4 B TR X4 52 73 e 4 B A1 1 (¥ 1k 7

(Process).

1.

AN

®

1t Standard Objects X% Haxrr, L+ Static Text(ifa3CA);

FERTT NKT11 B BT 57— Sem e

BN NK111, $RJ5H% Enter #;

A B ST SOARAE, JEFE Properties;

1E Colors £ i, ¥ Background Color fil Border Color & Mk
&

KN 5 PR AR ;

7. BSOS, WAZSCAREL A NP1, KRR e R A2 I

i

- AZFERED BRI ESORNE, R W

6-9
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6.9 ZEiiET5IEERERE

LR A R JEURHRE 1, BLE 2O S N g 0 T e BRERE,
A0 Suh s IR VAV, 1) 24 i -

M WO N -

o1

1%+ Properties;

¥ Tag Assignment;

HT R JEURLREW AL bR R, AN A D A4 B S Fill Level AT
Dynamic ZIf AT EE,

EF Tag..., HIUPREENE 1

MAibr%E RMTULE 1M1/LIAU, FREEPERS IRHRE, FREEXTTEE A 3%
Hl, ST AR ks

IS B S8 P R T ;

6.10 #EAMER(Faceplate)

6-10

EA S A FCT1T AU ET] NK111—NK114 fiiitk. ZER S 1105
B, TR BRI IR RCE R JE ARG . g e OLE #4F
BT, AR RRON KR Dbk

1.
2.

0 N O

9.

7£ Smart Objects X% H sk i $ Control (15 4F);
ERITT NK111 BT @ —A 84 3em 58, 1em &), HI Insert a
Control %fiGHE;

MRS R $E PCS 7 VALVE Control, /iy OK, #isE 7 Iheehmisk
7,

c RN  BRTTHE R . BRI AR, AR H sk XL Dynamic

Wizard Frid,

#3)) Dynamic Wizard 2| WK L; #EA4 2] Dynamic Wizard H%,
Al FE 44 View > Toolbars , il Dynamic Wizard MEFHE, $TI75)
A FIhE;

# Dynamic Wizard % ik

1#¢ Standard Dynamics % 71 ;

Xili Connect picture block to tag structure(¥ K& 5 45 M brasiE %)
EBhAIR S, &P Next $440;

10. riiZEHESHA ) Button $24H],

11.

JEEFRZE RMT1/NK111/Valve, sl OK, BEES AW 1iER:,



FEPHIRAT DA

2. f£ Set Options XIif#HE, st Next %4, # F —XHiGHE, s

Finish;

BfE, R C2 5XMNVN R ShaebuER:. R, HEEIBWT:

1.

X, fF PCS 7 Control Properties H11£3% Symbol % 7T

2. CRFIRIB S8 & (Width) B #4110,

3. FiE(Height)i% & 4 50;

4. Xili Tag Name JGIHIH visible SCA, SCARAE invisible, &4 RIS
71 s

5. siili OK %4, 1B H B X UGHE;

AL E S EEE A ARG

Position Control Type Connection

To the right of valve NP111 |PCS 7 MOTOR Control RMT1/NP111/Motor

To the right of valve FC111 |PCS 7 CTRL_PID Control RMT1/FC111/Ctlr

To the right of valve NK112 |PCS 7 VALVE Control RMT1/NK112/Valve

Above valve NK 113 PCS 7 VALVE Control RMT1/NK113/Valve

Above valve NK 114 PCS7 VALVE Control RMT1/NK114/Valve

BIPAE L, BATCAIEATTER AT, SeR 7R R m i wit, 1%
WP IRIE

1. H File > Save 3¢ &A1 RMT1;

2.
3.

6.11 &%

H File > Exit i iy & % A ETE & 15
i YES #%41#5iM 5 )& Save changes in Status.PDL;

R RRIER A

FAICg T H COLOR HIZHAs, 45 CFC FIl SFC 4z, s il
HAE. a0 TG SEEA Mg A & E P14 2% (Transfer) 45 #
1 i o

—_

a M WON

. P#:31) SIMATIC Manager % I1;

WP iy 4 Options>PLC-OS Connect Data > Transfer;
762598 1 Introduction, #EH Next #4401 ;
fLF% 2, HNEH T WInCC #%4, #E$E Next $44l;

SR 3, KM S7/M7 Programs & ¥ S7 Program(1) 3 il 34 1
Operator Stations % I-1ff] Operation Station I, #RfF%+# Next %41l

6. LA, S A ME T OS K A HEA S7 Program (1)K £ AE
7. EFAME DK S7 Program, fidi Connection #%4], EFI21TH H T

A AR B AT R R X 25, A AR MPL 2%, SR )5 4% OK 24
KM
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6.12

6-12

. Rith Next %41
. fEDIR 5, BEFUWIN Transfer Options i£:

- fEiE¥dE: Tags and Message, SFC Visualization, Picture Tree;
- #37ids%: Transfer Log;

- {&i%. All Fl Clear operator station(s);

- Lb#: Tag Names Fl address, units, designation, operator text;
SR st Next 328 ;

10. fr:% 6, fiidi Change-driven transfer K0 #HE, 45 OS uifgE 1A ID
1, S7 Program #55& F555 1D 2. #&5xH ID 5H T4 EDC Chart Thig
iz 4, AR)5 miihi Next 124 ;

11. giili Transfer #2451, JAahfki%: RPN E G TG LUATAE 2 12

12. ALX 4%, #il{s B Transfer was executed without errors and
warnings, 5EIER

RARE R

BMCAL AL AAE, WETLIYE PC ML EEBhEIT &4 &17 1

(), SSAE AR D VRIS IR . B 3is AT bR F

1. H Windows NT toolbar > WinCCExplorer i# NERE 536 (K] WinCC 3 %

2.

s
HERSE 414 File > Activate, #:AE Ruhgt NIET 7,

FGUHG ) Ir) S5 PR X S A4 AR N 14, SR i s mT T e B 7 AL U e 2 AN )

14|

i, fm RMT1 8¢ RMT2,

PR RMTT,  %80] 7 2 JsURHRE VR -

A
1.
2.

D 01 b~ W

7.

TIABh R R, AZ0E3) SFC YiRek], SERuWT:
Hiili Keyset Change %41
stk SFC Visualization fiz4ilal
1P SFC UiRelEl SFC_RMT1,;
Rl OK, HiBL SFC IhAEE I M5
M DhBERI 2 X, B SFC ThRE R Ve SR,
TRk b ki
i OK P4 SFC - 1E % M5

SFC Thfieliaaha, ML AER LAHa T, Hardaa L LLks 0 Ror, B
AT LRI R IR ST R AT T 0 e B 2 AE (B 10), WIS 28
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AR A A (S 00) A AL B 25 PR (R €) o 4 AT IEAE A S H0 B BoR A first

address Fll second address %1/,

HIREA W E, SFC BT AN 52, BIRMNE 1 MECE . ek

AR N PR, WG SCATR IR /0 5, BSENCh 0, F—JE3) SFC

N, WEEATRNVEE 2 IECE

o Y REBGERT, S AR B R R R LT, SEERATA
M I T AN AR R B

o TETTHAH PSR AR, 7‘5&% sk Alarm Logging 341 [,
B E B ATE fE BAR S

o JTIR[F RMT1 i FEmifh, il Previous Graphic Picture 341 [ .

o T MEFIEAERI], £F RMT1 T A S FCmAR, FTITII PRSI
Ho 7 WShRedek B A Fah =0, Bl 7EEAE Rl BEAER .

o BRI IHRAE RukfK) SFC Visualization #AET, R RIERE %
AT, 2 OK 24N %1 B

o UL FEREHASE TG ARSI ERE, ] R R
o MELEHIZAT, s Exit Runtime %401 MU 75 B0 0T AE ik
Deactivate 41 :

Are you sure to deactivate the runtime session 7

If you agree push the "deactivate” button.

A, AT T R SRR RN, RS AL IR S R R

Ul FRATTIE A 2 T We] FET B A B3 S A K A SR . e 4 e i T

MIZ RGN, BAT ST FA DR AE W AN 2RI R .

BATIE2E 2] T WD 8 I S5 i FE S B0k Bz . JE I 4 AN SRR THIRCR

/0 48, A1) T WIinCC fy—Lexhfe, oA~ > T Tl &SR sh A

el JH s s AT

ZETH COLOR 1, BAITCENFEHRE 2 MHASIET —SerE & . A,

] f N AR 0 BT a7 JFURIEE 2 (4 A i ] -

1. 7€ Plant View 7, ¥ RMT1, $R/54E RMT2 (12 V5046 N % m]
fis

2. K DU H E 4% 08 RMT2;

3. ALREEHISS SEAE UG EREWE, S0 6.11 WP, EELALIERIEE
ATIRAS
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6-14

4. FTITmE RMT2, $3C7BHO0 EURNE 2 (307, i) NK111 220 191

NK211;
5. AT S, FTIFASIIEHE, B ECRE B b 8% 8, W
RMT1_NK111_Valve.QOPENED %2>} RMT2_NK211_Valve.QOPENED;
R TR, A8 5RO 1 32
A Rl 17O SIS NIUEAE, &M 1/O ShIIAR 2% HE
A6 CSUTE 1T 1A b 28 T
- AP, E IS AT RN B P 2
FNIAE R IE, AT M AN AHEE.

© 00 N o



MisR— HaBRIE

CFC Continuous Function Chart, #4ET)RER]

DB Data Block, #fitk

ES Engineering Station, T f&ifisk

FB Function Block, Zhfgdl, 501 DB Prfr s
FC Function Code, DhRefUid, JoHlfyy DB Hefr st
OB Organization Block, ZHZ{Hk

OCM Operator Control and Monitoring, #4F G 2 A1 AR
0S Operator Station, #{F b1k

PCS Process Control System, s R 48

PG Programming Device, #ifiss

PH Plant Hierarchy, 1) JZ2k45H

SFC Sequential Function Chart, Jiii/5zh g &

STEP7 SIMATIC S7 WA IT A 3R 55
WinCC Windows Control Center, R #HIHLy, FTHAE G2k i AMLI 4R 14

b1
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